Leave a comment (0) 作者:adwin

正常使用npm run start或直接electron .运行和调试项目的时候,都没有什么问题,但是使用electron-package构建项目之后,发现跑不起来,通过打开资源目录发现有几个node_modules第三方包没有被打包进去,找到这些包的安装位置之后手动复制进去就OK了。

但是为什么会发生这样的情况呢?最后找到原因是package.json里边没有这些包的依赖,猜想可能是因为没有在当前项目目录下npm install吧,所以package.json里边没有进行更新,解决的话也很简单,加入到package.json文件中就可以了,类似这样:

...
"author": "",
  "license": "ISC",
  "devDependencies": {
    "electron": "^8.0.1"
  },
  "dependencies": {
    "fs": "^0.0.1-security",
    "node-7z": "^2.1.1",
    "sql.js": "^1.2.2",
    "axios": "^0.19.2",
    "iconv-lite": "^0.5.1",
    "safer-buffer": "^2.1.2"
  }
...

我本来没有axios等几个包,都是后边自己手动加进去之后就OK了。

分类:技术文档 | 标签: electron nodejs
分享到:

我也说两句 »